Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 11, 2026 - 09:00 CET
Scheduled
Please be advised that a maintenance operation will take place on our server, it shouldn't imply any service outage, but you may experience some DNS resolution issues for a few minutes.
We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Feb 09, 2026 - 13:22 CET
This scheduled maintenance affected: UK Region (Consumer, API).